desktop/inf.jpg mobile/inf.jpg

Задание 9. Кодирование и декодирование информации. Работа с файлами. ЕГЭ 2023 по информатике

За это задание ты можешь получить 1 балл. На решение дается около 5 минут. Уровень сложности: базовый.
Средний процент выполнения: 63%
Ответом к заданию 9 по информатике может быть цифра (число) или слово.
Разбор сложных заданий в тг-канале

Задачи для практики

Задача 1

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите сколько существует строк, в которых сумма квадратов максимального и минимального значения больше, чем произведение оставшихся.

Решение

Для начала нужно расположить числа по возрастанию (или убыванию)

Для этого запишем формулы, в ячейки соседние с числами:
=НАИБОЛЬШИЙ(A1:E1;1)
=НАИБОЛЬШИЙ(A1:E1;2)
=НАИБОЛЬШИЙ(A1:E1;3)
=НАИБОЛЬШИЙ(A1:E1;4)
=НАИБОЛЬШИЙ(A1:E1;5)

Далее найдём сумму квадратов наибольшего и наименьшего: =F1^2+J1^2
и произведение оставшихся: =G1*H1*I1:

Проверим в каких строчках соблюдается условие: =ЕСЛИ(K1>L1;1;0)

После этого, просто найдём сумму столбца: =СУММ(M:M) Это и будет нашим ответом.

Ответ: 23
Показать решение
Полный курс

Задача 2

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел, координаты и радиус двух окружностей: x1, y1, r1, x2, y2, r2. Определите количество строк, в которых эти две окружности касаются, пересекаются или одна окружность находится внутри другой. В ответе запишите только число.

Решение

В данном случае достаточно проверить, что расстояние между окружностями меньше или равно сумме их радиусов.

Воспользуемся формулой: =ЕСЛИ(КОРЕНЬ((D1-A1)^2+(E1-B1)^2)<=C1+F1;1;0)

Посчитать количество окружностей, удовлетворяющих условию: =СУММ(H:H)

В ответе запишем полученный результат.

Ответ: 6692
Показать решение
Полный курс

Задача 3

Откройте файл электронной таблицы, содержащей в первой строке координаты центра и радиус окружности (x, y, R), в каждой последующей строке два целых числа, координаты точки: x1, y1. Найдите количество точек, которые лежат на окружности с центром в точке x, y и радиуса R. При решении нужно воспользоваться уравнением окружности. В ответе запишите только одно число.

Решение

В общем виде уравнение окружности выглядит следующим образом: (x – a)2 + (y – b)2 = R2, где a и b – координаты центра окружности.

Для начала нужно проверить, лежит точка на окружности или нет, если точка находится на окружности, то поставить 1, иначе 0: =ЕСЛИ((A2-\$A\$1)^2+(B2-\$B\$1)^2=\$C\$1^2;1;0)

Обратите внимание на то, что некоторые ссылки являются абсолютными, т.к. уравнение окружности применимо только для первой строки из таблицы.

Посчитать количество точек, которые расположены на окружности можно по формуле: =СУММ(D:D)

В ответе запишем полученный результат.

Ответ: 5
Показать решение
Полный курс

Задача 4

Откройте файл электронной таблицы, содержащей в первой строке координаты центра и радиус окружности (x, y, R), в каждой последующей строке два целых числа, координаты точки: x1, y1. Найдите сколько точек лежит внутри круга с центром в точке x, y и радиуса R. При решении можно воспользоваться уравнением окружности. В ответе запишите только одно число.

Решение

В общем виде уравнение окружности выглядит следующим образом: (x – a)2 + (y – b)2 = R2, где a и b – координаты центра окружности.

Для начала нужно проверить, лежит точка внутри окружности или нет, если точка находится внутри окружности, то поставить 1, иначе 0: =ЕСЛИ((A2-\$A\$1)^2+(B2-\$B\$1)^2<\$C\$1^2;1;0)

Обратите внимание на то, что некоторые ссылки являются абсолютными, т.к. уравнение окружности применимо только для первой строки из таблицы.

Посчитать количество точек, которые расположены внутри окружности можно по формуле: =СУММ(D:D)

В ответе запишем полученный результат.

Ответ: 134
Показать решение
Полный курс

Задача 5

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа, координаты двух точек, начала и конца отрезка: x1, y1, x2, y2. Найдите количество отрезков, у которых длина больше 30 и не больше 50. При решении воспользоваться формулой вычисления длины отрезка по двум точкам. В ответе запишите только целую число.

Решение

Длина отрезка вычисляется по формуле: =КОРЕНЬ((A1-C1)^2+(B1-D1)^2)

Найдём количество отрезков, удовлетворяющих условию задачи =СЧЁТЕСЛИМН(E:E;">30";E:E;"<=50")

В ответе запишем полученное число.

Ответ: 2136
Показать решение
Полный курс

Задача 6

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа, координаты двух точек, начала и конца отрезка: x1, y1, x2, y2. Найдите максимальную длину среди всех отрезков. При решении воспользоваться формулой вычисления длины отрезка по двум точкам. В ответе запишите только целую часть числа.

Решение

Длина отрезка вычисляется по формуле: =КОРЕНЬ((A1-C1)^2+(B1-D1)^2)

Найдём наибольшее значение, при условии, что длины отрезков записаны в столбце Е: =МАКС(E:E)

В результате получим 126,732

В ответе запишем только целую часть.

Ответ: 126
Показать решение
Полный курс

Задача 7

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Назовём тройку "подходящей", если в ней среднее по величине число равно среднему арифметическому большего и меньшего чисел: b = (a+c)/2. Посчитайте количество "подходящих" троек. В ответе запишите только число.

Решение

Чтобы определить наибольшее из чисел, воспользуемся формулой в ячейке E1: =МАКС(A1:C1)

Чтобы определить наименьшее из чисел, воспользуемся формулой в ячейке F1: =МИН(A1:C1)

Чтобы определить среднее число, воспользуемся формулой в ячейке G1: =СУММ(A1:C1)-МАКС(A1:C1)-МИН(A1:C1)

Формулу из условия проверим функцией: =ЕСЛИ(G1*2=E1+F1;1;0)

Посчитаем количество строк, принимающих единицу в финальном столбце столбцах. Таких 17.

Ответ: 17.

Ответ: 17
Показать решение
Полный курс

Задача 8

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Назовём тройку "подходящей", если в ней самое большее число равно сумме удвоенного среднего (по величине) числа и утроенного меньшего числа: a = 2b+3c. Посчитайте количество "подходящих" троек. В ответе запишите только число.

Решение

Чтобы определить наибольшее из чисел, воспользуемся формулой в ячейке E1: =МАКС(A1:C1)

Чтобы определить наименьшее из чисел, воспользуемся формулой в ячейке F1: =МИН(A1:C1)

Чтобы определить среднее число, воспользуемся формулой в ячейке G1: =СУММ(A1:C1)-МАКС(A1:C1)-МИН(A1:C1)

Формулу из условия проверим функцией: =ЕСЛИ(E1=2*G1+3*F1;1;0)

Посчитаем количество строк, принимающих единицу в финальном столбце столбцах. Такая только одна.

Ответ: 1.

Ответ: 1
Показать решение
Полный курс

Задача 9

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Определите максимальную площадь треугольника, который можно составить из троек чисел. При решении воспользоваться неравенством треугольника и формулой Герона. В ответе запишите только одно число - значение максимальной площади, округлённое до целого.

Решение

Согласно неравенству треугольника, в любом треугольнике сумма длин двух сторон всегда должна быть больше третьей. Чтобы проверить неравенство треугольника, достаточно убедиться, что сумма длин двух наименьших сторон больше длины наибольшей стороны. Площадь треугольника будем находить по формуле Герона.

Чтобы определить наибольший из отрезков, воспользуемся формулой в ячейке E1: =МАКС(A1:C1)

Чтобы определить наименьший из отрезков, воспользуемся формулой в ячейке F1: =МИН(A1:C1)

Чтобы определить средний отрезок, воспользуемся формулой в ячейке G1: =СУММ(A1:C1)-МАКС(A1:C1)-МИН(A1:C1)

Чтобы определить полупериметр, воспользуемся формулой в ячейке H1: =СУММ(A1:C1)/2

Неравенство треугольника проверим формулой =ЕСЛИ(E1<F1+G1;1;0)

Добавим в эту формулу вместо единицы формулу Герона: =ЕСЛИ(E1<F1+G1;КОРЕНЬ(H1*(H1-E1)*(H1-F1)*(H1-G1));0)

Максимальную площадь найдём поиском максимума в столбце площадей: =МАКС(I:I)

Наибольшая площадь: 3942,653. Округлив до целого, получим окончательный ответ: 3943.

Ответ: 3943.

Ответ: 3943
Показать решение
Полный курс

Задача 10

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Определите количество троек чисел, из которых возможно составить треугольник согласно неравенству треугольника. В ответе запишите только число.

Решение

Согласно неравенству треугольника, в любом треугольнике сумма длин двух сторон всегда должна быть больше третьей. Чтобы проверить неравенство треугольника, достаточно убедиться, что сумма длин двух наименьших сторон больше длины наибольшей стороны.

Чтобы определить наибольший из отрезков, воспользуемся формулой в ячейке E1: =МАКС(A1:C1)

Чтобы определить наименьший из отрезков, воспользуемся формулой в ячейке F1: =МИН(A1:C1)

Чтобы определить средний отрезок, воспользуемся формулой в ячейке G1: =СУММ(A1:C1)-МАКС(A1:C1)-МИН(A1:C1)

Неравенство треугольника проверим формулой =ЕСЛИ(E1<F1+G1;1;0)

Посчитаем количество единиц в финальном столбце, получим 528 подходящих троек.

Ответ: 528.

Ответ: 528
Показать решение
Полный курс

Задача 11

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа - координаты концов отрезка x1, y1, x2, y2 соответственно. Определите количество отрезков, расположенных горизонтально (параллельно оси Ох). В ответе запишите только число.

Решение

Отрезок параллелен оси Ох, если y1 = y2.

В ячейку F1 запишем =ЕСЛИ(B1=D1;1;0)

Посчитаем количество единиц в финальном столбце F, получим 12 подходящих отрезков.

Ответ: 12.

Ответ: 12
Показать решение
Полный курс

Задача 12

Откройте файл электронной таблицы, содержащей в каждой строке три натуральных числа. Определите максимальную площадь треугольника, который можно составить из троек чисел. При решении воспользоваться неравенством треугольника и формулой Герона. В ответе запишите только одно число - значение максимальной площади, округлённое до целого.

Решение

Согласно неравенству треугольника, в любом треугольнике сумма длин двух сторон всегда должна быть больше третьей. Чтобы проверить неравенство треугольника, достаточно убедиться, что сумма длин двух наименьших сторон больше длины наибольшей стороны. Площадь треугольника будем находить по формуле Герона.

Чтобы определить наибольший из отрезков, воспользуемся формулой в ячейке E1: =МАКС(A1:C1)

Чтобы определить наименьший из отрезков, воспользуемся формулой в ячейке F1: =МИН(A1:C1)

Чтобы определить средний отрезок, воспользуемся формулой в ячейке G1: =СУММ(A1:C1)-МАКС(A1:C1)-МИН(A1:C1)

Чтобы определить полупериметр, воспользуемся формулой в ячейке H1: =СУММ(A1:C1)/2

Неравенство треугольника проверим формулой =ЕСЛИ(E1<F1+G1;1;0)

Добавим в эту формулу вместо единицы формулу Герона: =ЕСЛИ(E1<F1+G1;КОРЕНЬ(H1*(H1-E1)*(H1-F1)*(H1-G1));0)

Максимальную площадь найдём поиском максимума в столбце площадей: =МАКС(I:I)

Наибольшая площадь: 3658,396. Округлив до целого, получим окончательный ответ: 3658.

Ответ: 3658.

Ответ: 3658
Показать решение
Полный курс

Задача 13

Откройте файл электронной таблицы, содержащей натуральные числа - еженедельные замеры стоимости автомобилей в течение года. В какой месяц средняя цена на все автомобили была максимальная? В ответ запишите целую часть максимальной средней цены.

Решение

Откроем файл электронной таблицы. В удобной для вас пустой ячейке (например, в ячейке Q2) запишем формулу =СРЗНАЧ(B2:P6), чтобы посчитать среднее арифметическое значение цены на автомобили в январе. Аналогичным образом считаем среднее арифметическое значение цены автомобилей в другие месяцы. Для удобства формулы будем записывать в ячейки Q3-Q13 включительно. Теперь нужно выбрать из получившихся чисел наибольшее. Для этого в любой свободной ячейке запишем формулу =МАКС(Q2:Q13). Получается 566682,5167. В ответ записываем только целую часть (не округляем!), получается ответ 566682.

Ответ: 566682
Показать решение
Полный курс

Задача 14

Откройте файл электронной таблицы, содержащей натуральные числа - результаты ежечасного замера температуры воздуха в течение трёх месяцев. Найдите разность между средним арифметическим значением температуры в апреле и средним арифметическим значением температуры в марте. В ответ запишите только целую часть получившего числа.

Решение

Откроем файл электронной таблицы. В удобной для вас пустой ячейке (например, в ячейке Z2) запишем формулу =СРЗНАЧ(B2:Y32), чтобы посчитать среднее арифметическое значение температуры в марте. В другой пустой ячейке запишем формулу =СРЗНАЧ(B33:Y62), чтобы посчитать среднее арифметическое значение температуры в апреле. Теперь нужно вычесть первое число из второго. Получается 10,51890681. В ответ записываем только целую часть (не округляем!), получается ответ 10.

.
Ответ: 10
Показать решение
Полный курс

Задача 15

Откройте файл электронной таблицы, содержащей натуральные числа - результаты ежедневных продаж крепёжных материалов на протяжении шести месяцев. Найдите разность между материалами, проданными за всё время, и материалами, проданными за лето.

Решение

Откроем файл электронной таблицы. В удобной для вас пустой ячейке (например, в ячейке N2) записываем формулу =СУММ(B2:M184), чтобы посчитать количество товаров, проданных за всё время. В соседней пустой ячейке (например, в ячейке N3) записываем формулу =СУММ(B63:M154), чтобы посчитать количество материалов, проданных за лето. Теперь нам осталось найти разность двух чисел. Для удобства можно посчитать разность в таблице. Получается ответ 2751277.

Ответ: 2751277
Показать решение
Полный курс

Задача 16

Откройте файл электронной таблицы, содержащей натуральные числа - результаты ежедневных продаж крепёжных материалов на протяжении шести месяцев. Найдите, каких крепёжных материалов продали за сентябрь больше всего, а каких - меньше всего. Посчитайте разность этих чисел.

Решение

Откроем файл электронной таблицы. В удобной для вас пустой ячейке (например, в ячейке B185) записываем формулу =СУММ(B155:B184), чтобы посчитать количество проданных гвоздей 15 мм за сентябрь. Далее нужно посчитать количество остальных проданных товаров за сентябрь. Для удобства тянем за правый нижний угол ячейки с формулой вправо, до ячейки M185 включительно. Теперь необходимо узнать, какого материала было продано больше всего, а какого - меньше всего, и посчитать разность этих чисел. Для удобства в пустой ячейке (например, в ячейке N185) запишем формулу =МАКС(B185:M185)-МИН(B185:M185). Получилось число 16154, которое является ответом.

Ответ: 16154
Показать решение
Полный курс
Показать еще

Готовим к ЕГЭ на 85+ баллов и побеждаем лень

Каждый месяц 12 онлайн-занятий в дружелюбной атмосфере + 16 домашних работ с жесткими сроками.
Не готовишься — вылетаешь.

Подробнее о курсе